sites
Theme Alerts
Get a list of themes reporting security issues
get/sites/{id}/security-alerts/themes
Request
- Base URLhttps://my.pressable.com/v1
- Authnone declared
- TypeScriptA function with typed inputs. Its response is checked against the schema.
Path parameters
idinteger required
Response
Successful Response
Example response
{
"message": "Success",
"data": {
"active": [
{
"id": 62,
"site_id": 495,
"name": "Divi",
"version": "4.15.1",
"status": "active",
"active": true,
"update_available": false,
"update_version": null,
"security_risk": true,
"security_alerts": [
{
"title": "Divi < 4.25.2 - Contributor+ Stored XSS",
"description": "The theme is vulnerable to Stored Cross-Site Scripting due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"severity": "medium",
"fixed_in": "4.25.2",
"reference_urls": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/6571a899-f217-434f-bbed-b1faf77a8d8b"
]
},
{
"title": "Elegant Themes Divi Theme, Extra Theme, Divi Page Builder <= 4.25.0 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting",
"description": "The Elegant Themes Divi theme, Extra theme, and Divi Page Builder plugin for WordPress are vulnerable to DOM-Based Stored Cross-Site Scripting via the ‘title’ parameter in versions up to, and including, 4.25.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"severity": "medium",
"fixed_in": "4.25.1",
"reference_urls": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/efac70f6-d959-41f7-bdef-d554f1c9133e"
]
},
{
"title": "Divi < 4.23.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode",
"description": "The Divi theme for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'et_pb_text' shortcode in all versions up to, and including, 4.23.1 due to insufficient input sanitization and output escaping on user supplied custom field data. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"severity": "medium",
"fixed_in": "4.23.2",
"reference_urls": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/999475c5-5f17-47fa-a0d0-47cb5a8a0eb4"
]
},
{
"title": "Divi < 4.20.3 - Contributor+ Stored XSS",
"description": "The theme does not validate and escape some parameters, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks",
"severity": "medium",
"fixed_in": "4.20.3",
"reference_urls": []
}
]
}
]
}
}Changes
No recorded changes to this operation across all 2 revisions of this API.