LDAP Configuration

Verify LDAP Configuration in One Project

Verifies the LDAP configuration for the specified project.

post/api/atlas/v2/groups/{groupId}/userSecurity/ldap/verify

Request

  • Base URL
    https://cloud.mongodb.com
  • URL
    https://cloud.mongodb.com/api/atlas/v2/groups/{groupId}/userSecurity/ldap/verify
  • Auth
    • OAuth 2
      Client credentials
      Token URL: https://cloud.mongodb.com/api/oauth/token
    • or HTTP digest

Path parameters

groupIdstring required
Example:32b6e34b3d91647abb20e7b8

Unique 24-hexadecimal digit string that identifies your project. Use the /groups endpoint to retrieve all projects to which the authenticated user has access.

NOTE: Groups and projects are synonymous terms. Your group id is the same as your project id. For existing groups, your group/project id remains the same. The resource and corresponding endpoints use the term groups.

Query parameters

envelopeboolean

Flag that indicates whether Application wraps the response in an envelope JSON object. Some API clients cannot access the HTTP response headers or status code. To remediate this, set envelope=true in the query. Endpoints that return a list of results use the results object as an envelope. Application adds the status parameter to the response body.

prettyboolean

Flag that indicates whether the response body should be in the prettyprint format.

Request body

authzQueryTemplatestring

Lightweight Directory Access Protocol (LDAP) query template that MongoDB Cloud applies to create an LDAP query to return the LDAP groups associated with the authenticated MongoDB user. MongoDB Cloud uses this parameter only for user authorization.

Use the {USER} placeholder in the Uniform Resource Locator (URL) to substitute the authenticated username. The query relates to the host specified with the hostname. Format this query per RFC 4515 and RFC 4516.

bindPasswordstring required

Password that MongoDB Cloud uses to authenticate the bindUsername.

bindUsernamestring required

Full Distinguished Name (DN) of the Lightweight Directory Access Protocol (LDAP) user that MongoDB Cloud uses to connect to the LDAP host. LDAP distinguished names must be formatted according to RFC 2253.

caCertificatestring

Certificate Authority (CA) certificate that MongoDB Cloud uses to verify the identity of the Lightweight Directory Access Protocol (LDAP) host. MongoDB Cloud allows self-signed certificates. To delete an assigned value, pass an empty string: "caCertificate": "".

hostnamestring required

Human-readable label that identifies the hostname or Internet Protocol (IP) address of the Lightweight Directory Access Protocol (LDAP) host. This host must have access to the internet or have a Virtual Private Cloud (VPC) peering connection to your cluster.

portinteger required

IANA port to which the Lightweight Directory Access Protocol (LDAP) host listens for client connections.

Example request

{
  "authzQueryTemplate": "{USER}?memberOf?base",
  "bindUsername": "CN=BindUser,CN=Users,DC=myldapserver,DC=mycompany,DC=com",
  "links": [
    {
      "href": "https://cloud.mongodb.com/api/atlas",
      "rel": "self"
    }
  ]
}

Response

OK

Changes

No recorded changes to this operation across all 1 revision of this API.