routes

POST /projects/{project}/global/routes

Changed on

Creates a Route resource in the specified project using the data included in the request.

Request

  • Base URL
    https://compute.googleapis.com/compute/v1
  • URL
    https://compute.googleapis.com/compute/v1/projects/{project}/global/routes
  • Auth
    • OAuth 2 and OAuth 2
      Implicit: https://accounts.google.com/o/oauth2/auth
      Scopes: https://www.googleapis.com/auth/cloud-platform
      Authorization code: https://accounts.google.com/o/oauth2/auth
      Token URL: https://accounts.google.com/o/oauth2/token scopes: https://www.googleapis.com/auth/cloud-platform
    • or OAuth 2 and OAuth 2
      Implicit: https://accounts.google.com/o/oauth2/auth
      Scopes: https://www.googleapis.com/auth/compute
      Authorization code: https://accounts.google.com/o/oauth2/auth
      Token URL: https://accounts.google.com/o/oauth2/token scopes: https://www.googleapis.com/auth/compute

Path parameters

projectstring required

Project ID for this request.

Query parameters

requestIdstring

An optional request ID to identify requests. Specify a unique request ID so that if you must retry your request, the server will know to ignore the request if it has already been completed.

For example, consider a situation where you make an initial request and the request times out. If you make the request again with the same request ID, the server can check if original operation with the same request ID was received, and if so, will ignore the second request. This prevents clients from accidentally creating duplicate commitments.

The request ID must be a valid UUID with the exception that zero UUID is not supported (00000000-0000-0000-0000-000000000000).

Request body

creationTimestampstring

Output only. [Output Only] Creation timestamp inRFC3339 text format.

descriptionstring

An optional description of this resource. Provide this field when you create the resource.

destRangestring

The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.

idstring uint64

Output only. [Output Only] The unique identifier for the resource. This identifier is defined by the server.

kindstring

Output only. [Output Only] Type of this resource. Always compute#routes for Route resources.

namestring

Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply withRFC1035. Specifically, the name must be 1-63 characters long and match the regular expression [a-z]([-a-z0-9]*[a-z0-9])?. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.

networkstring

Fully-qualified URL of the network that this route applies to.

nextHopGatewaystring

The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/project/global/gateways/default-internet-gateway

nextHopHubstring

Output only. [Output Only] The full resource name of the Network Connectivity Center hub that will handle matching packets.

nextHopIlbstring

The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs:

  - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule 
  • regions/region/forwardingRules/forwardingRule

If an IP address is provided, must specify an IPv4 address in dot-decimal notation or an IPv6 address in RFC 4291 format. For example, the following are all valid IP addresses:

  - 10.128.0.56
  - 2001:db8::2d9:51:0:0
  - 2001:db8:0:0:2d9:51:0:0

IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.

nextHopInstancestring

The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/

nextHopInterRegionCostinteger

Output only. [Output only] Internal fixed region-to-region cost that Google Cloud calculates based on factors such as network performance, distance, and available bandwidth between regions.

nextHopInterconnectAttachmentstring

Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for dynamic routes generated by Cloud Router with a linked interconnectAttachment or the static route generated by each L2 Interconnect Attachment.

nextHopIpstring

The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.

nextHopMedinteger

Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates the desirability of a particular route in a network.

nextHopNetworkstring

The URL of the local network if it should handle matching packets.

nextHopOrigin'EGP' | 'IGP' | 'INCOMPLETE'

Output only. [Output Only] Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE.

nextHopPeeringstring

Output only. [Output Only] The network peering name that should handle matching packets, which should conform to RFC1035.

nextHopVpnTunnelstring

The URL to a VpnTunnel that should handle matching packets.

priorityinteger

The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is 1000. The priority value must be from 0 to 65535, inclusive.

routeStatus'ACTIVE' | 'DROPPED' | 'INACTIVE' | 'PENDING'

[Output only] The status of the route. This status applies to dynamic routes learned by Cloud Routers. It is also applicable to routes undergoing migration.

routeType'BGP' | 'STATIC' | 'SUBNET' | 'TRANSIT'

Output only. [Output Only] The type of this route, which can be one of the following values:

  • 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers
  • 'SUBNET' for a route from a subnet of the VPC
  • 'BGP' for a route learned from a BGP peer of this router
  • 'STATIC' for a static route
selfLinkstring

[Output Only] Server-defined fully-qualified URL for this resource.

tagsstring[]

A list of instance tags to which this route applies.

Response

Successful response

clientOperationIdstring

[Output Only] The value of requestId if you provided it in the request. Not present otherwise.

creationTimestampstring

[Deprecated] This field is deprecated.

descriptionstring

[Output Only] A textual description of the operation, which is set when the operation is created.

endTimestring

[Output Only] The time that this operation was completed. This value is inRFC3339 text format.

httpErrorMessagestring

[Output Only] If the operation fails, this field contains the HTTP error message that was returned, such as NOT FOUND.

httpErrorStatusCodeinteger

[Output Only] If the operation fails, this field contains the HTTP error status code that was returned. For example, a 404 means the resource was not found.

idstring uint64

[Output Only] The unique identifier for the operation. This identifier is defined by the server.

insertTimestring

[Output Only] The time that this operation was requested. This value is inRFC3339 text format.

kindstring

Output only. [Output Only] Type of the resource. Always compute#operation for Operation resources.

namestring

[Output Only] Name of the operation.

operationGroupIdstring

Output only. [Output Only] An ID that represents a group of operations, such as when a group of operations results from a bulkInsert API request.

operationTypestring

[Output Only] The type of operation, such as insert, update, or delete, and so on.

progressinteger

[Output Only] An optional progress indicator that ranges from 0 to 100. There is no requirement that this be linear or support any granularity of operations. This should not be used to guess when the operation will be complete. This number should monotonically increase as the operation progresses.

regionstring

[Output Only] The URL of the region where the operation resides. Only applicable when performing regional operations.

selfLinkstring

[Output Only] Server-defined URL for the resource.

startTimestring

[Output Only] The time that this operation was started by the server. This value is inRFC3339 text format.

status'DONE' | 'PENDING' | 'RUNNING'

[Output Only] The status of the operation, which can be one of the following: PENDING, RUNNING, or DONE.

statusMessagestring

[Output Only] An optional textual description of the current status of the operation.

targetIdstring uint64

[Output Only] The unique target ID, which identifies a specific incarnation of the target resource.

targetLinkstring

[Output Only] The URL of the resource that the operation modifies. For operations related to creating a snapshot, this points to the disk that the snapshot was created from.

userstring

[Output Only] User who requested the operation, for example: user@example.com or alice_smith_identifier (global/workforcePools/example-com-us-employees).

zonestring

[Output Only] The URL of the zone where the operation resides. Only applicable when performing per-zone operations.

Changes

    • info

      the security scope https://www.googleapis.com/auth/cloud-platform was added to the endpoint's security scheme Oauth2

    • info

      the security scope https://www.googleapis.com/auth/cloud-platform was added to the endpoint's security scheme Oauth2c

    • info

      the security scope https://www.googleapis.com/auth/compute was removed from the endpoint's security scheme Oauth2

    • info

      the security scope https://www.googleapis.com/auth/compute was removed from the endpoint's security scheme Oauth2c

    • info

      the security scope https://www.googleapis.com/auth/cloud-platform was added to the endpoint's security scheme Oauth2

    • info

      the security scope https://www.googleapis.com/auth/cloud-platform was added to the endpoint's security scheme Oauth2c

    • info

      the security scope https://www.googleapis.com/auth/compute was removed from the endpoint's security scheme Oauth2

    • info

      the security scope https://www.googleapis.com/auth/compute was removed from the endpoint's security scheme Oauth2c