/
RA
rage
/
Main Frontend API
Search skmtc…
⌘K
Changes
Docs
Sign in
Sign in
APIs
5
Docs
History
Schema
Filter operations
certificates
6
chapters
6
chatbot-models
2
chatbots
5
code_giveaways
7
course_auditing
2
course_modules
7
course-credit-registrations
11
course-instances
15
course-plans
15
course-stats
28
course-students
9
courses
66
credit-registration-admin
34
credit-registrations
16
email_templates
3
email-verification
4
exams
11
exercise_repositories
5
exercise_services
5
exercise_slide_submissions
3
exercises
11
feedback
1
files
2
global-stats
7
glossary
4
oauth
17
get
/api/v0/main-frontend/oauth/.well-known/openid-configuration
Handles `/.well-known/openid-configuration` to expose OIDC discovery metadata.
get
/api/v0/main-frontend/oauth/authorize
post
/api/v0/main-frontend/oauth/authorize
get
/api/v0/main-frontend/oauth/authorized-clients
delete
/api/v0/main-frontend/oauth/authorized-clients/{client_id}
post
/api/v0/main-frontend/oauth/consent
Handles `/consent` approval after the user agrees to grant requested scopes.
post
/api/v0/main-frontend/oauth/consent/deny
Handles `/consent/deny` when the user refuses to grant scopes.
post
/api/v0/main-frontend/oauth/device_authorization
Handles `POST /device_authorization` — the RFC 8628 device authorization endpoint.
get
/api/v0/main-frontend/oauth/device_verification
Handles `GET /device_verification` — render data for the browser consent page.
post
/api/v0/main-frontend/oauth/device_verification/approve
Handles `POST /device_verification/approve`.
post
/api/v0/main-frontend/oauth/device_verification/deny
Handles `POST /device_verification/deny`.
post
/api/v0/main-frontend/oauth/introspect
Handles the `/introspect` endpoint for OAuth 2.0 token introspection (RFC 7662).
get
/api/v0/main-frontend/oauth/jwks.json
Handles `/jwks.json` for returning the JSON Web Key Set (JWKS).
post
/api/v0/main-frontend/oauth/revoke
Handles the `/revoke` endpoint for OAuth 2.0 token revocation (RFC 7009).
post
/api/v0/main-frontend/oauth/token
Handles the `/token` endpoint for exchanging authorization codes or refresh tokens.
get
/api/v0/main-frontend/oauth/userinfo
post
/api/v0/main-frontend/oauth/userinfo
org
1
organizations
16
page_audio
3
pages
8
playground-examples
4
playground-views
2
proposed_edits
3
regradings
4
roles
4
shared_submissions
4
status
11
teacher_grading_decisions
1
time
1
user-details
10
users
18
oauth
Copy Markdown
Copied
Copy failed
Changes to Handles the `/introspect` endpoint for OAuth 2.0 token introspection (RFC 7662).
post
/api/v0/main-frontend/oauth/introspect
Aug 21, 2026
e0a02e8a30b9
Revision changes
○
added the non-success response with the status
401
Ask about this API