/
CO
coder
Search skmtc…
⌘K
Docs
Sign in
Docs
History
Schema
Generate
Filter operations
Agents
28
AI Gateway
5
AI Providers
5
Applications
2
Audit
2
Authorization
7
Builds
13
Chats
95
Debug
15
Enterprise
115
get
/.well-known/oauth-authorization-server
OAuth2 authorization server metadata.
get
/.well-known/oauth-protected-resource
OAuth2 protected resource metadata.
get
/api/experimental/ai/model-prices
List AI model prices
post
/api/experimental/ai/model-prices
Upsert AI model prices
get
/api/experimental/organizations/{organization}/ai/spend/users
List organization AI spend by user
get
/api/v2/agent-firewall/sessions/{id}
Get agent firewall session by ID
get
/api/v2/agent-firewall/sessions/{id}/logs
Get agent firewall session logs
get
/api/v2/ai-gateway/keys
List AI Gateway keys
post
/api/v2/ai-gateway/keys
Create AI Gateway key
delete
/api/v2/ai-gateway/keys/{key}
Delete AI Gateway key
get
/api/v2/ai-gateway/serve
AI Gateway serve
get
/api/v2/appearance
Get appearance
put
/api/v2/appearance
Update appearance
post
/api/v2/applications/reconnecting-pty-signed-token
Issue signed app token for reconnecting PTY
get
/api/v2/connectionlog
Get connection logs
post
/api/v2/deployment/premium-funnel-events
Report a premium paywall click
get
/api/v2/entitlements
Get entitlements
get
/api/v2/groups
Get groups
get
/api/v2/groups/{group}
Get group by ID
delete
/api/v2/groups/{group}
Delete group by name
patch
/api/v2/groups/{group}
Update group by name
get
/api/v2/groups/{group}/ai/budget
Get group AI budget
put
/api/v2/groups/{group}/ai/budget
Upsert group AI budget
delete
/api/v2/groups/{group}/ai/budget
Delete group AI budget
get
/api/v2/groups/{group}/ai/spend
Get group AI spend
get
/api/v2/groups/{group}/members
Get group members by group ID
get
/api/v2/groups/{group}/members/ai/spend
Get group members AI spend
get
/api/v2/licenses
Get licenses
post
/api/v2/licenses
Add new license
post
/api/v2/licenses/refresh-entitlements
Update license entitlements
post
/api/v2/licenses/trial
Request a trial license
delete
/api/v2/licenses/{id}
Delete license
put
/api/v2/notifications/templates/{notification_template}/method
Update notification template dispatch method
get
/api/v2/oauth2-provider/apps
Get OAuth2 applications.
post
/api/v2/oauth2-provider/apps
Create OAuth2 application.
get
/api/v2/oauth2-provider/apps/{app}
Get OAuth2 application.
put
/api/v2/oauth2-provider/apps/{app}
Update OAuth2 application.
delete
/api/v2/oauth2-provider/apps/{app}
Delete OAuth2 application.
get
/api/v2/oauth2-provider/apps/{app}/secrets
Get OAuth2 application secrets.
post
/api/v2/oauth2-provider/apps/{app}/secrets
Create OAuth2 application secret.
delete
/api/v2/oauth2-provider/apps/{app}/secrets/{secretID}
Delete OAuth2 application secret.
get
/api/v2/oauth2-provider/settings
Get OAuth2 provider settings.
put
/api/v2/oauth2-provider/settings
Update OAuth2 provider settings.
get
/api/v2/organizations/{organization}/ai/spend/export
Export organization AI spend as CSV
get
/api/v2/organizations/{organization}/groups
Get groups by organization
post
/api/v2/organizations/{organization}/groups
Create group for organization
get
/api/v2/organizations/{organization}/groups/ai/spend
Get organization groups AI spend
get
/api/v2/organizations/{organization}/groups/{groupName}
Get group by organization and group name
get
/api/v2/organizations/{organization}/groups/{groupName}/members
Get group members by organization and group name
get
/api/v2/organizations/{organization}/groups/{groupName}/members/ai/spend
Get group members AI spend by organization
get
/api/v2/organizations/{organization}/members/{user}/workspace-quota
Get workspace quota by user
get
/api/v2/organizations/{organization}/paginated-groups
Get groups by organization (paginated)
get
/api/v2/organizations/{organization}/provisionerdaemons/serve
Serve provisioner daemon
get
/api/v2/organizations/{organization}/provisionerkeys
List provisioner key
post
/api/v2/organizations/{organization}/provisionerkeys
Create provisioner key
get
/api/v2/organizations/{organization}/provisionerkeys/daemons
List provisioner key daemons
delete
/api/v2/organizations/{organization}/provisionerkeys/{provisionerkey}
Delete provisioner key
get
/api/v2/organizations/{organization}/settings/idpsync/available-fields
Get the available organization idp sync claim fields
get
/api/v2/organizations/{organization}/settings/idpsync/field-values
Get the organization idp sync claim field values
get
/api/v2/organizations/{organization}/settings/idpsync/groups
Get group IdP Sync settings by organization
patch
/api/v2/organizations/{organization}/settings/idpsync/groups
Update group IdP Sync settings by organization
patch
/api/v2/organizations/{organization}/settings/idpsync/groups/config
Update group IdP Sync config
patch
/api/v2/organizations/{organization}/settings/idpsync/groups/mapping
Update group IdP Sync mapping
get
/api/v2/organizations/{organization}/settings/idpsync/roles
Get role IdP Sync settings by organization
patch
/api/v2/organizations/{organization}/settings/idpsync/roles
Update role IdP Sync settings by organization
patch
/api/v2/organizations/{organization}/settings/idpsync/roles/config
Update role IdP Sync config
patch
/api/v2/organizations/{organization}/settings/idpsync/roles/mapping
Update role IdP Sync mapping
get
/api/v2/organizations/{organization}/settings/workspace-sharing
Get workspace sharing settings for organization
patch
/api/v2/organizations/{organization}/settings/workspace-sharing
Update workspace sharing settings for organization
get
/api/v2/provisionerkeys/{provisionerkey}
Fetch provisioner key details
get
/api/v2/replicas
Get active replicas
get
/api/v2/settings/idpsync/available-fields
Get the available idp sync claim fields
get
/api/v2/settings/idpsync/field-values
Get the idp sync claim field values
get
/api/v2/settings/idpsync/organization
Get organization IdP Sync settings
patch
/api/v2/settings/idpsync/organization
Update organization IdP Sync settings
patch
/api/v2/settings/idpsync/organization/config
Update organization IdP Sync config
patch
/api/v2/settings/idpsync/organization/mapping
Update organization IdP Sync mapping
get
/api/v2/templates/{template}/acl
Get template ACLs
patch
/api/v2/templates/{template}/acl
Update template ACL
get
/api/v2/templates/{template}/acl/available
Get template available acl users/groups
post
/api/v2/templates/{template}/prebuilds/invalidate
Invalidate presets for template
get
/api/v2/users/{user}/ai/budget/override
Get user AI budget override
put
/api/v2/users/{user}/ai/budget/override
Upsert user AI budget override
delete
/api/v2/users/{user}/ai/budget/override
Delete user AI budget override
get
/api/v2/users/{user}/ai/spend
Get user AI spend
get
/api/v2/users/{user}/quiet-hours
Get user quiet hours schedule
put
/api/v2/users/{user}/quiet-hours
Update user quiet hours schedule
get
/api/v2/workspace-quota/{user}
Get workspace quota by user deprecated
get
/api/v2/workspaceproxies
Get workspace proxies
post
/api/v2/workspaceproxies
Create workspace proxy
post
/api/v2/workspaceproxies/me/app-stats
Report workspace app stats
get
/api/v2/workspaceproxies/me/coordinate
Workspace Proxy Coordinate
get
/api/v2/workspaceproxies/me/crypto-keys
Get workspace proxy crypto keys
post
/api/v2/workspaceproxies/me/deregister
Deregister workspace proxy
post
/api/v2/workspaceproxies/me/issue-signed-app-token
Issue signed workspace app token
post
/api/v2/workspaceproxies/me/register
Register workspace proxy
get
/api/v2/workspaceproxies/{workspaceproxy}
Get workspace proxy
delete
/api/v2/workspaceproxies/{workspaceproxy}
Delete workspace proxy
patch
/api/v2/workspaceproxies/{workspaceproxy}
Update workspace proxy
get
/api/v2/workspaces/{workspace}/external-agent/{agent}/credentials
Get workspace external agent credentials
get
/oauth2/authorize
OAuth2 authorization request (GET - show authorization page).
post
/oauth2/authorize
OAuth2 authorization request (POST - process authorization).
get
/oauth2/clients/{client_id}
Get OAuth2 client configuration (RFC 7592)
put
/oauth2/clients/{client_id}
Update OAuth2 client configuration (RFC 7592)
delete
/oauth2/clients/{client_id}
Delete OAuth2 client registration (RFC 7592)
post
/oauth2/register
OAuth2 dynamic client registration (RFC 7591)
post
/oauth2/revoke
Revoke OAuth2 tokens (RFC 7009).
post
/oauth2/tokens
OAuth2 token exchange.
delete
/oauth2/tokens
Delete OAuth2 application tokens.
get
/scim/v2/ServiceProviderConfig
SCIM 2.0: Service Provider Config
get
/scim/v2/Users
SCIM 2.0: Get users
post
/scim/v2/Users
SCIM 2.0: Create new user
get
/scim/v2/Users/{id}
SCIM 2.0: Get user by ID
put
/scim/v2/Users/{id}
SCIM 2.0: Replace user account
patch
/scim/v2/Users/{id}
SCIM 2.0: Update user account
Files
2
General
13
Git
5
InitScript
1
Insights
5
MCP
11
Members
11
Notifications
16
Organizations
19
PortSharing
3
Prebuilds
2
Provisioning
1
Secrets
6
TemplateBuilder
5
Templates
38
Users
40
WorkspaceProxies
1
Workspaces
24
Enterprise
Copy
Copy Markdown
Copy Markdown
Copying…
Copied
Copy failed
Changes to Update group by name
patch
/api/v2/groups/{group}
May 4, 2026
6865e861885f
Revision changes
info
endpoint added