---
title: "Get all remote action of vehicle and callback."
method: GET
path: "/fleets/{fid}/vehicles/{vid}/callbacks/{cbid}/remotes"
tags: ["Remote"]
---

# Get all remote action of vehicle and callback.

`GET /fleets/{fid}/vehicles/{vid}/callbacks/{cbid}/remotes`

## Request

- Base URL: `https://api-cert.groupe-psa.com/connectedcar/v3`
- URL: `https://api-cert.groupe-psa.com/connectedcar/v3/fleets/{fid}/vehicles/{vid}/callbacks/{cbid}/remotes`
- Auth: HTTP basic and API key in query parameter `client_id`

Returns the list of action remote requested for vehicle.

## Path parameters

- `fid` string, required
- `vid` string, required
- `cbid` string, required

## Query parameters

- `indexRange` string: Range index used to express the first (offset) and the last results index to retrieve. With the respect to the regex pattern '\d+(-\d*)?', the start of range is mandatory (use 0 for default). *Example:* * '0-9' : start=0, end=9 ==> offset=0 and number of items=10 * '5-' : start =5, no end ==> start at 5th to the end results.
- `pageSize` integer
- `pageToken` string

## Response `200`

A list of remote actions.

- RemoteActions
  - `_links` TabLinks, required: [HAL](https://en.wikipedia.org/wiki/Hypertext_Application_Language#Convention) (Hypertext Application Language) link collection
    - `self` Link, required: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
      - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
      - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
      - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
      - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
      - `name` string
      - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
      - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
      - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
    - `first` Link, required: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
      - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
      - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
      - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
      - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
      - `name` string
      - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
      - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
      - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
    - `next` Link: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
      - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
      - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
      - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
      - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
      - `name` string
      - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
      - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
      - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
    - `prev` Link: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
      - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
      - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
      - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
      - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
      - `name` string
      - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
      - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
      - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
    - `last` Link: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
      - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
      - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
      - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
      - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
      - `name` string
      - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
      - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
      - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
  - `total` integer, required
  - `totalPage` integer, required
  - `currentPage` integer, required
  - `_embedded` object, required
    - `remoteActions` RemoteAction[]
      - `remoteActionId` string: The uniq remote action ID returned when the remote action was posted and accepted.
      - `status` 'Accepted' | 'Failed' | 'Success' | 'AlreadyDone' | 'WakingUpVehicle' | 'CheckingVehicle' | 'SentToVehicle' | 'VehicleBatteryChargeTooLow' | 'TooManyWakeUpsOverMonth'
      - `type` 'ThermalPreconditioning' | 'ElectricBatteryChargingRequest' | 'Horn' | 'Doors' | 'Lights' | 'Immobilization' | 'Stolen' | 'WakeUp' | 'Navigation'
      - `_links` object, required
        - `fleet` Link: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
          - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
          - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
          - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
          - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
          - `name` string
          - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
          - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
          - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
        - `callback` Link: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
          - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
          - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
          - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
          - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
          - `name` string
          - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
          - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
          - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
        - `self` Link, required: A Link Object as defined by [JSONHAL#Link Object](https://tools.ietf.org/html/draft-kelly-json-hal-08#section-5).
          - `href` string, required: URL format follows [RFC 3986](https://tools.ietf.org/html/rfc3986) and usually looks like this ` scheme://host[:port][/Path] `
          - `templated` boolean: SHOULD be true when the Link Object's "href" property is an [URI Template](https://tools.ietf.org/html/rfc6570)
          - `type` string: a hint to indicate the media type expected when dereferencing the target resource.
          - `deprecation` string: indicates that the link is to be deprecated (i.e. removed) at a future date. Its value is a URL that SHOULD provide further information about the deprecation.
          - `name` string
          - `title` string: Its value is a string and is intended for labelling the link with a human-readable identifier (as defined by [RFC5988](https://tools.ietf.org/html/rfc5988)).
          - `profile` string: Its value is a string and is intended for indicating the language of the target resource (as defined by [RFC5988]).
          - `hreflang` string: Its value is a string which is a URI that hints about the profile (as defined by [I-D.wilde-profile-link](https://tools.ietf.org/html/draft-kelly-json-hal-08#ref-I-D.wilde-profile-link)) of the target resource.
      - `remote` Remote: Remote vehicle activation. ```Only one action``` (horn, precond, door...) is supported at a time.
        - `label` string
        - `preconditioning` RemotePreconditioning: Remote preconditioning the vehicle.
          - `airConditioning` object, required: At least one of the parameters must be provided.
            - `immediate` boolean: Determines whether air conditioning will start immediately or not independently if scheduled ```programs``` are set or not. Set to "false" by default.
            - `programs` object[]: List of air conditioning programs to schedule on vehicle.
              - …
        - `immobilization` RemoteSetImmobilization: Requesting the vehicle for immobilization.
          - `activate` boolean, required: Set, if ```true```, the vehicle as immobilized or not (otherwise).
        - `door` RemoteDoorsState: Remote vehicle door (lock/unlock) state. _Disclaimer_ : "Forced" parameter is only applicable to lock the doors and is now deprecated because not applicable to all vehicles. It will be ignored to unlock the doors if set. Some additionnal details will be added in the callback when this parameter is considered.
          - `state` 'Unlocked' | 'Locked', required
          - `forced` boolean
        - `horn` RemoteHorn: Remote vehicle horn activation.
          - `state` 'Activated' | 'Unactivated', required: Activate or unactivate this remote horn.
        - `charging` RemoteCharging: Remote electric battery charging action. - ```preferences``` cannot be used in the same remote than ```schedule``` and/or ```immediate```
          - `nextDelayedTime` string: (!Depricated; use schedule instead) Timestamp (as defined in [RFC3339](https://www.ietf.org/rfc/rfc3339.txt)) of the next battery charging time.
          - `schedule` object: Charge scheduling. Only one of the two modes, programs or nexDelayedTime, should be provided.
            - `nextDelayedTime` string: Timestamp (as defined in [RFC3339](https://www.ietf.org/rfc/rfc3339.txt)) of the next battery charging time.
            - `programs` object[]: Scheduled charging programs list.
              - …
          - `immediate` boolean: Determines if the charging will start immediately(```True```) or not.
          - `preferences` object: Set the charging preferences.
            - `level` 'Level1' | 'Level2' | 'Level3' | 'Level4' | 'Level5': Charging power level.
            - `type` 'Partial' | 'Full': Configure charging type preferences.
        - `stolen` RemoteStolen: Remote operation to update stolen state, immobilization and configuration information. Only one attribute can be used at a time.
          - `stolen` boolean: Declare the vehicle stolen or not (set at ```True``` to report as stolen).
          - `trackingPeriod` object: Modify vehicle data collection frequency through tracking timer attributes.
            - `running` integer: Data collection frequency when vehicle is in stolen mode and ignition On
            - `shutdown` integer: Data collection frequency when vehicle is in stolen mode and ignition Off
          - `immobilization` object: Requesting the stolen vehicle for immobilization.
            - `activate` boolean, required: Set, if ```true```, the vehicle as immobilized or not (otherwise).
        - `lights` RemoteLights: Remote to swith on / off lights.
          - `on` boolean, required: Swith, if ```true```, the vehicle lights ON or OFF (otherwise).
        - `wakeUp` RemoteWakeUp: Remote to wake up a vehicle (so it can update its data).
          - `action` string
        - `navigation` RemoteNavigation: A remote to share GPS positions with the vehicle so it can navigate through those positions by driving from start (1st) to end (last) position. It can include only 9 points + the destination.
          - `driverApproval` boolean: Whether sharing position with vehicle requires driver approval or not.
          - `positions` Point[], required
            - `coordinates` number[], required: This is a simple 2 (or more) numbers vector used to define Geometry Point objects.
            - `type` 'Point', required
      - `failureCause` 'GeneralError' | 'VehicleError' | 'WrongCommand' | 'VehicleConnectionTimeout' | 'MissingRights' | 'NotPossibleDueToVehicleBatteryLevel' | 'NotPossibleDueToVehiclePrivacyLevel' | 'TooManyWakeUpsOverMonth' | 'TooManyRequestInShortTime' | 'SameActionInProgress' | 'NotPossibleDueToVehicleStolenState' | 'VehicleInUse' | 'TooManyRequestSent' | 'DoorsOpen' | 'VehicleErrorOrCidInside' | 'CidInside' | 'ExternalChargingSystemError' | 'VehicleChargingSystemError' | 'VehicleIsNotLocked' | 'CanceledByDriver': The failure cause for event with failed status. This field is filled only is failure state.
      - `feedbackDetail` 'NoCIDBlacklisted' | 'CIDBlacklisted': Additionnal detail in case of success on some specific behavior : |Feature|Description|Behavior| |----------|:-------------|------:| |Lock Doors|Send a lock doors by force|NoCIDBlacklisted if lock is OK but IML not blacklisted, CIDBlacklisted is when the doors are locked and the IML is well blacklisted|

## Other responses

- `default` (unresolved $ref)

---

[API](https://skmtc.dev/groupe-psa/apis/groupe-psa-connected-car-b2b-api.md) - [All operations](https://skmtc.dev/groupe-psa/apis/groupe-psa-connected-car-b2b-api/llms.txt) - [OpenAPI document](https://skmtc.dev/groupe-psa/apis/groupe-psa-connected-car-b2b-api/revisions/023ff3e3fe51?raw)
